Dokumentation

Voraussetzungen

Das ep-3 Buchungssystem ist eine Webanwendung. Zur Installation und Inbetriebnahme ist daher ein Webserver notwendig.

Systemvoraussetzungen

Empfohlen wird jeweils die aktuellste stabile Version.

  • Apache HTTP Server 2+
    • mod_rewrite
  • MySQL 5+
  • PHP 5.4+
    • intl-Extension
  • Zend Framework 2.3+

Empfohlen wird außerdem ein Linux-Betriebssystem.

Alternativen

Die Abhängigkeit vom Apache Webserver bezieht sich hauptsächlich auf den Einsatz der Rewrite-Engine (mod_rewrite). Wird die .htaccess-Datei manuell ausgetauscht, kann natürlich auch eine andere Webserver-Software verwendet werden.

Das Buchungssystem basiert auf dem Zend Framework 2.3+ und profitiert von dessen Abstraktionsmechanismen. Insbesondere lässt sich mit etwas Geschick auch eine andere von ZF2 unterstützte Datenbanksoftware einsetzen.

Verfasst von: Tobias Krebs
Stand: Juni 2014